Jump to content


These Forums Are Now Read-Only


For TubePress support, please post a question here or open a support ticket and we will be glad to assist.


Photo

Responsive Player Getting Double Top Padding


Best Answer eric, 25 June 2015 - 08:20 PM

I've added a support article for this here. If anyone needs help implementing the suggested solution found there, please open a ticket and we'll be glad to assist.

Go to the full post


  • This topic is locked This topic is locked
7 replies to this topic

#1 bloggerbash

bloggerbash

    Newbie

  • TubePress Pro
  • Pip
  • 3 posts

Posted 02 June 2015 - 03:49 PM

I have a Pro install at http://bloggerbash.com/videos/and the main player's containers are getting double top padding, creating a white space above the player. Oddly, both the .tubepress-fluid-width-video-wrapper AND .fluid-width-video-wrapper get the top padding.

 

EDIT: I noticed that FitVids was being loaded by the Divi theme. Is it duplicating the responsive functionality that TubePress is trying to implement? If I disable responsive embeds in the TP options, sadly, the video dimensions override what FitVids is trying to do :(  Any idea how to make these 2 play nice?

 

Thanks



#2 bloggerbash

bloggerbash

    Newbie

  • TubePress Pro
  • Pip
  • 3 posts

Posted 02 June 2015 - 04:19 PM

I figured out a very ugly band-aid for this using some jQuery in an 'optional code' field in Divi's theme options. Not a permanent fix, just wanted you to know why it looks OK if you look at the above URL.

setTimeout( 
   function(){ 
      jQuery('.tubepress-fluid-width-video-wrapper').css({ 'paddingTop':0, 'position':'initial' 
   }); 
}, 3000 );


#3 brandon

brandon

    Advanced Member

  • TubePress Staff
  • 1,989 posts

Posted 03 June 2015 - 01:20 AM

bloggerbash,

 

If you disable the "responsive embeds" feature, the spacing will go away.  This is a known bug which will be fixed in the next release.

 

Thanks!


Want a faster, more personalized support experience? Open a ticket with us! We will be gradually phasing out forum-based support in favor of a proper ticketing system. Please help us help you!


#4 bloggerbash

bloggerbash

    Newbie

  • TubePress Pro
  • Pip
  • 3 posts

Posted 03 June 2015 - 04:10 PM

Brandon, thanks for your response, but we need the functionality that comes along with the responsive embeds. So, I guess I'll leave my band-aid in place until the plugin is updated. Thanks



#5 gizorama

gizorama

    Newbie

  • TubePress Pro
  • Pip
  • 1 posts

Posted 15 June 2015 - 01:55 PM

Bumping this issue. Still an issue with 4.1.9, have already tried disabling all other plugins.

 

Is there a 4.1.3 download? All I can find in the download section is 4.1.7+



#6 brandon

brandon

    Advanced Member

  • TubePress Staff
  • 1,989 posts

Posted 17 June 2015 - 02:33 AM

hey sorry been on vacation. I've poked our developers about this.

 

Thanks!


Want a faster, more personalized support experience? Open a ticket with us! We will be gradually phasing out forum-based support in favor of a proper ticketing system. Please help us help you!


#7 eric

eric

    Lead Developer

  • TubePress Staff
  • 2,787 posts

Posted 22 June 2015 - 02:57 AM

Hello!

 

I noticed that FitVids was being loaded by the Divi theme. Is it duplicating the responsive functionality that TubePress is trying to implement? If I disable responsive embeds in the TP options, sadly, the video dimensions override what FitVids is trying to do :(  Any idea how to make these 2 play nice?

 

Your suspicion is correct; both Divi/Fitvids and TubePress are both trying to make videos on your website responsive. TubePress actually "keeps to its own" and only works with TubePress-generated videos, but Fitvids kinda goes nuclear and tries to update every video it sees.

 

So we have the following solutions:

  1. Disable TubePress's responsive embeds, which is disabling a very important feature.
     
  2. Disable the responsive video functionality entirely from Divi. This is only a viable solution if TubePress is the only thing that will ever embed a video on your website (probably unlikely).
     
  3. Tell Fitvids to ignore TubePress videos.

Option #3 is what I would strongly suggest. You'll just need to edit line 70 of wp-content/themes/Divi/js/jquery.fitvids.js and change it from:

var $allVideos = $(this).find(selectors.join(','));

to

var $allVideos = $(this).find(selectors.join(',')).not('.js-tubepress-embed');

That should be it. Give it a try and let us know how it works?



#8 eric

eric

    Lead Developer

  • TubePress Staff
  • 2,787 posts

Posted 25 June 2015 - 08:20 PM   Best Answer

I've added a support article for this here. If anyone needs help implementing the suggested solution found there, please open a ticket and we'll be glad to assist.