Jump to content


These Forums Are Now Read-Only


For TubePress support, please post a question here or open a support ticket and we will be glad to assist.


Photo

Vimeo Videos Not Showing


  • Please log in to reply
9 replies to this topic

#1 eseel

eseel

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 24 May 2015 - 08:01 PM

Could someone please check my tubepress page here (www.fashinvest.com/videos)?

 

The code I used on the page is as follows:

[tubepress mode="vimeoChannel + tag" tagValue="fashion investment" vimeoChannelValue="FashInvest"]

 

The page is obviously showing some different video other than those I am trying for it to show. What am I doing wrong. 



#2 brandon

brandon

    Advanced Member

  • TubePress Staff
  • 1,989 posts

Posted 26 May 2015 - 09:06 PM

Hello,

 

When I provided this shortcode I missed a few quote marks. Please try this instead:

[tubepress mode="'vimeoChannel' + 'tag'" tagValue="fashion investment" vimeoChannelValue="FashInvest"]

 

Thanks!


Want a faster, more personalized support experience? Open a ticket with us! We will be gradually phasing out forum-based support in favor of a proper ticketing system. Please help us help you!


#3 eseel

eseel

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 27 May 2015 - 08:21 AM

Still no luck.  It is still not showing videos from our vimeo account.  Thoughts? 

 

http://www.fashinves...ubepress_page=1



#4 brandon

brandon

    Advanced Member

  • TubePress Staff
  • 1,989 posts

Posted 27 May 2015 - 08:52 PM

eseel,

 

When I pasted that exact code into my dev environment, it tells me that the Vimeo channel can't be embedded on my site (not authorized) so it should be working properly.  Are you using the text or visual editor?

 

Thanks!


Want a faster, more personalized support experience? Open a ticket with us! We will be gradually phasing out forum-based support in favor of a proper ticketing system. Please help us help you!


#5 eseel

eseel

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 28 May 2015 - 08:38 PM

I tried both ways.  I am not getting any vimeos videos, only you tube.



#6 eric

eric

    Lead Developer

  • TubePress Staff
  • 2,787 posts

Posted 02 June 2015 - 04:53 PM

Looks like the issue is that you have the free/trial version of TubePress installed, which isn't capable of combining YouTube and Vimeo. The solution is to simply delete your existing copy of TubePress then download and install a fresh copy of TubePress Pro. That should get things working again. Give it a try?

 

Thanks!



#7 eseel

eseel

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 02 June 2015 - 06:24 PM

Ok I did it.  Is there a way in settings to know if I am using the pro version? I installed the pro version but the settings dont show it is the pro. Still no luck showing Vimeo videos.



#8 eric

eric

    Lead Developer

  • TubePress Staff
  • 2,787 posts

Posted 02 June 2015 - 11:28 PM

If you take a look at WP Admin > Plugins, you should see "TubePress Pro" as an active plugin instead of just "TubePress". Looks like you are currently running the Pro version - great!

 

Looking at your debug output, it looks to me like there is a syntax error in your shortcode. Particularly the "mode" value seems to have an issue. Could you verify that this is the exact shortcode that you are using?

[tubepress mode="vimeoChannel + tag" tagValue="fashion investment" vimeoChannelValue="FashInvest"]

It's always a good idea to use WordPress's "Text Editor" instead of the "Visual Editor" when editing shortcodes.



#9 eseel

eseel

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 03 June 2015 - 07:55 AM

That definitely helped. I retyped the code and it is showing the correct youtube videos however still no vimeo. I am thinking now it has something to do with my settings.  Could I have something wrong in my setting that will stop it from showing Vimeo?  Also will the code you gave me show the vimeo videos first and then you tube?  All our videos are hosted on Vimeo so I want it to show the vimeo channel first before the you tube.



#10 eric

eric

    Lead Developer

  • TubePress Staff
  • 2,787 posts

Posted 03 June 2015 - 03:35 PM

We're almost there! I'm going to send you a PM with instructions to get Vimeo working once and for all.

 

Also will the code you gave me show the vimeo videos first and then you tube?  All our videos are hosted on Vimeo so I want it to show the vimeo channel first before the you tube.

 

The Vimeo and YouTube videos will be intermingled on each page. You'll want to adjust the per-page sort order from WP Admin > Settings > TubePress > Feed > per-page sort order. If you set that to "none", then all of your Vimeo videos will show up before your YouTube videos.