Jump to content


These Forums Are Now Read-Only


For TubePress support, please post a question here or open a support ticket and we will be glad to assist.


Photo

Error Recursivedirectoryiterator::getrelativepath() With Tubepress Pro 4.5.1 Standalone_Php

standalone-php youtube tubepress-pro

  • Please log in to reply
6 replies to this topic

#1 sinoefk

sinoefk

    Newbie

  • TubePress Pro
  • Pip
  • 2 posts

Posted 27 April 2015 - 04:24 AM

Hello,

I just did an update of TubePress Pro standalone php 2.4.5 to version 4.1.5 to fix the video youtube.com/devicesupport on the site of one of my clients.

By installing the new version I have the following PHP error :

Fatal error: Call to undefined method RecursiveDirectoryIterator :: getRelativePath () in /htdocs/public/www/tubepress_pro_4_1_5/vendor/ehough/finder/src/main/php/ehough/finder/iterator/ExcludeDirectoryFilterIterator.php on line 43 .

The PHP version on the server is 5.2.5 and I can not update it .

Please, Could you help me to solve this issue.

Thanks

Sinoe



#2 bielanskia

bielanskia

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 27 April 2015 - 01:06 PM

I am having an issue with devicesupport as well. I am on version 4.16. I updated the API key to verison 3 but still no luck. 

http://ccchowchilla.com/watch-sermons/



#3 brandon

brandon

    Advanced Member

  • TubePress Staff
  • 1,989 posts

Posted 27 April 2015 - 09:17 PM

Hello,

I just did an update of TubePress Pro standalone php 2.4.5 to version 4.1.5 to fix the video youtube.com/devicesupport on the site of one of my clients.

By installing the new version I have the following PHP error :

Fatal error: Call to undefined method RecursiveDirectoryIterator :: getRelativePath () in /htdocs/public/www/tubepress_pro_4_1_5/vendor/ehough/finder/src/main/php/ehough/finder/iterator/ExcludeDirectoryFilterIterator.php on line 43 .

The PHP version on the server is 5.2.5 and I can not update it .

Please, Could you help me to solve this issue.

Thanks

Sinoe

You need to update your PHP version, preferably to 5.5 and update your TubePress plugin to 4.1.6 (latest as of this writing)

 

Thanks!


Want a faster, more personalized support experience? Open a ticket with us! We will be gradually phasing out forum-based support in favor of a proper ticketing system. Please help us help you!


#4 brandon

brandon

    Advanced Member

  • TubePress Staff
  • 1,989 posts

Posted 27 April 2015 - 09:21 PM

I am having an issue with devicesupport as well. I am on version 4.16. I updated the API key to verison 3 but still no luck. 

http://ccchowchilla.com/watch-sermons/

Could you please verify you have installed and activate the Pro version of Tubepress, and removed/uninstalled previous versions of TubePress, including any Free Trial versions?

 

Thanks!


Want a faster, more personalized support experience? Open a ticket with us! We will be gradually phasing out forum-based support in favor of a proper ticketing system. Please help us help you!


#5 sinoefk

sinoefk

    Newbie

  • TubePress Pro
  • Pip
  • 2 posts

Posted 28 April 2015 - 07:00 AM

Hello Brandon,

 

Thanks for your answer,

 

Unfortunately, I can't update the PHP version on the server .

 

Is there an older version of Tubepress pro which is compatible to php 5.2.5 and that does not display the device support warning video from Youtube (which is my first problem with TubePress_pro 2.4.5) ?

 

Or maybe I can find a solution with TubePress 2.4.5 (I already can hide the video on the feed on the first load), may the Youtube API stop running or the only problem is the warning video display ?

 

Thanks!



#6 bielanskia

bielanskia

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 28 April 2015 - 08:55 AM

 Yes i am on 4.1.6, it is Tube Press Pro. 



#7 brandon

brandon

    Advanced Member

  • TubePress Staff
  • 1,989 posts

Posted 28 April 2015 - 08:33 PM

Hello Brandon,

 

Thanks for your answer,

 

Unfortunately, I can't update the PHP version on the server .

 

Is there an older version of Tubepress pro which is compatible to php 5.2.5 and that does not display the device support warning video from Youtube (which is my first problem with TubePress_pro 2.4.5) ?

 

Or maybe I can find a solution with TubePress 2.4.5 (I already can hide the video on the feed on the first load), may the Youtube API stop running or the only problem is the warning video display ?

 

Thanks!

Unfortunately,  we highly recommend upgrading your PHP installation, as older versions are no longer supported by the developers and therefore insecure.  Also unfortunately, with the API change by Google, you must update to 4.1.6 (latest as of now) in order for your gallery to continue to function.

 

Tubepress requires a minimum of 5.2.9.

 

Let us know.

Thanks!


Want a faster, more personalized support experience? Open a ticket with us! We will be gradually phasing out forum-based support in favor of a proper ticketing system. Please help us help you!






Also tagged with one or more of these keywords: standalone-php, youtube, tubepress-pro